Radeon RX580 not recognized as supported hardware

Hello,

First of all thank you for your work on Parsec!



I'm having an issue with Parsec and my RX580.
Parsec tells me that my computer is not able to host.

I am Windows 10 64bits, in dual-screen.

I have the same problem if I install a Radeon HD7870 (on the same computer), so I think the problem comes from my system.


Any idea of what could distort the detection of Parsec?

0

Comments

15 comments
  • Official comment

    Hey. We just bought one to figure out why it's not working. We believe it is due to the new VCE 4.0 library. We'll be able to address this pretty quickly now that we have a Vega GPU.

  • Thanks for your answer :) !

    The RX580 is a Polaris GPU with VCE 3.4, is it the same story than with Vega GPU and VCE 4.0 ?

  • Oh. Good call. That should work then. What version drivers do you have? Are you getting an error code when you try connecting? Is the RX580 listed in your display adapters on Device Manager?

  • I've got the latest Radeon Adrenalin drivers (18.8.2) and my RX580 is listed as display adapter.
    And i'm getting no error code.

    I think i'll need to do a fresh install of Windows

  • Parsec is just saying this cannot host?

  • Yes, no more informations at all

  • Okay. Then Parsec doesn't think you're running Windows 8.1 or 10 on that computer.

  • So it's certainly Windows 10 installation related.
    I'll do a fresh install then.

    Thanks for help and informations :)

  • I'm now on a fresh install of Windows 10 64bits (pro version) and Parsec still saying my computer cannot host (without any error code).


    Is there any parameter of windows that can interfere with Parsec ? Is it possible to force Parsec to allow hosting ?

  • I also have the same issue on my netbook with a I3-7100U processor (with Quick sync vidéo).

    So it's definitively a Windows issue.
    Does Parsec need specific Windows services / components ?

  • Can you tell me which build of windows you have? Also, if you open up the console on Parsec from the web browser, do you see a command app_get_binary_info? If you do, can you then open the dev tools from your browser, open the network tab, choose WS (or websockets), and find the websocket frame that has the function app_cfg_get. There should be a response that includes app_host. In my picture, you can see 0 because I'm on a Mac.

  • Thanks again for your help :) !


    I'm under Windows 10 Pro x64 build 1803.

    I've got the command "app_get_binary_info" in the console and the respond to app_cfg_get given is app_host = 0 (sreenshot below for details).

     

  • Here is the full app_cfg_get output in websockets :

     

      1. x-function:"app_cfg_get"
      2. x-json-status:0
      3. x-return:{app_channel: "release", app_lan_quality: 1, app_wan_quality: 1, app_console: 0, app_daemon: 1,…}
        1. app_api_endpoint:"parsecgaming.com"
        2. app_channel:"release"
        3. app_check_user_data:0
        4. app_console:0
        5. app_daemon:1
        6. app_first_drun:0
        7. app_first_run:1
        8. app_host:0
        9. app_ipc_origin:"[.%{CUSTOM | ORIGIN}%.]"
        10. app_lan_quality:1
        11. app_language:"en"
        12. app_log_endpoint:"log.parsec.tv"
        13. app_log_user_id:"0"
        14. app_native_ui:1
        15. app_silent:1
        16. app_ss_endpoint:"signal-load.parsec.tv"
        17. app_ss_port:443
        18. app_tray:1
        19. app_wan_quality:1
        20. client_audio_buffer:20000
        21. client_audio_mic_threshold:800
        22. client_fullscreen:0
        23. client_immersive:0
        24. client_overlay:1
        25. client_poll:1
        26. client_renderer:2
        27. client_renderer_jc:60
        28. client_vsync:1
        29. client_window_x:0
        30. client_window_y:0
        31. client_windowed:0
        32. decoder_software:0
        33. decoder_zero_copy:0
        34. encoder_bitrate:0
        35. encoder_fps:0
        36. encoder_h265:0
        37. encoder_idr_interval:0
        38. encoder_max_qp:-1
        39. encoder_min_bitrate:2
        40. encoder_min_qp:-1
        41. encoder_vbv_initial:100
        42. encoder_vbv_max:768
        43. encoder_vbv_multi:31
        44. host_capture_timeout:60
        45. host_output:"none"
        46. host_require_whitelist:0
        47. network_client_start_port:0
        48. network_cwindow_thresh:100
        49. network_ip_address:"127.0.0.1"
        50. network_mpegts_pid:0
        51. network_mtu:1290
        52. network_protocol:0
        53. network_server_start_port:0
        54. network_upnp:1
        55. server_admin_mute:1
        56. server_audio_bitrate:128
        57. server_audio_cancel:0
        58. server_audio_cancel_fade_ms:500
        59. server_audio_poll_rate:10
        60. server_max_clients:5
        61. server_refresh_rate:60
        62. server_resolution_x:1920
        63. server_resolution_y:1080
  • That is odd. You can use a workaround for now, but this shouldn't be happening on your PC. We're using a very specific Windows API that is well documented to confirm what version of Windows you're running. In the Parsec config.txt on your host, you can add this line: app_host=1

  • The workaround works well, thank you very much for your help and your time !

     


    I'm certain it's not due to a third party software because i tried with Parsec first installed on a new Win 10 installation (free from any other softwares). So it's Windows 10 related.

     

    Maybe some privacy settings can disrupt Windows version detection ?

Please sign in to leave a comment.

Didn't find what you were looking for?

New post