Discord Voice Chat Echo

Comments

18 comments

  • Official comment
    Avatar
    Benjy Boxer (Edited )

    Hey everyone. My best guess is that your virus scanner is blocking our discord integration. If harmony32.dll is not present in your Parsec folder after your friends have connected to you and you've chatted through Discord, some software might be blocking it from launching on your computer. The other thing to confirm is that you're using the Discord Standard Audio settings on the host. Experimental audio settings will not work with our integration. Can you make sure of that and try restarting Discord?

  • Avatar
    sevrlbats

    same here, echo cancel wasn't working for us, either! we restarted Parsec and Discord both--I will say neither of us had restarted our actual computer since installing Parsec. might that be the missing step? some piece of the install that needs to be finalized during a restart?

  • Avatar
    Andreas Scheutz

    We were using parsec for days now, so we restarted parsec and our computers several times by now. Guess we have to try the manual fix.

  • Avatar
    Maria Bovallius

    My friend and I have had this problem for days now as well, and I can't find any information on how to solve it online, save for the manual fix. We don't see harmony.exe running in the task manager, but even deactivating the virus scanner and trying again doesn't work. Is there a way to download just the harmony.exe file by itself?

  • Avatar
    Benjy Boxer

    Do you have a file in your Parsec folder called harmony32.dll? I'm really trying to figure out what could be stopping this integration from working. Did you use the manual fix before using the new echo cancel features? There might be some issue with how the manual fix changes the audio settings of your computer in a way that we're not able to cancel the echo. 

  • Avatar
    Maria Bovallius (Edited )

    We can't find the harmony32.dll file either, but even excluding the entire Parsec folder from the virus and threat protection scans in Windows Defender Security Center doesn't help. Any clue what other software might be causing this?

    Edit: No, we haven't tried the manual fix, neither before nor after this.

  • Avatar
    Benjy Boxer

    What's your virus scanner? If you don't have that file on the host, some virus scanner is definitely blocking it unless you have Discord experimental audio settings on. The way this works is that while someone is connected to you, we detect if Discord is running. If Discord is emitting sound, Parsec unpacks the Harmony32 dll and drops it into the folder (if everything is going right). Things that can stop this process from working are: virus scanner, Discord not being set up in standard audio mode, or something else. Can you rule out your virus scanner by turning it off and reinstalling Parsec on the host after quitting Parsec? If that fixes it, can you tell me what Virus Scanner you're using, so I can report to them that they're blocking a legitimate application? If that doesn't work, let me know. Thanks 

  • Avatar
    Maria Bovallius

    My friend (he's hosting) has Discord set up using the standard audio settings, and his only virus scanner is Windows Defender. He tried turning it off and reinstalling Parsec, after first quitting Parsec, but it didn't work.

  • Avatar
    Benjy Boxer

    What version of Windows is he using and how many bits? i.e. is it Windows 10 64 bit? Windows 10 32 bit?

  • Avatar
    Maria Bovallius

    He's using Windows 10 64 bit. He says he used Parsec a couple of months ago (before harmony) and had no problems with echo back then, and that nothing has changed on his computer since then.

  • Avatar
    Benjy Boxer

    What language is his PC? Is Discord appearing in Volume Mixer when he's getting sound from it? Is there another name for Discord on his PC?

  • Avatar
    Maria Bovallius

    His PC is in English, Discord is showing up in Volume Mixer, and it's just called "Discord".

  • Avatar
    sevrlbats

    in fact I was running a malwarebytes trial that might've been making mischief! I'll test this out when I get a chance with it stripped out, thank you!

  • Avatar
    JDoawp

    Can't find any Harmony32.dll haven't had a anti-virus in years and I just reinstalled it, no dll. Same with my friend. 

    Maybe just provide the DLL here so we can download it if we don't have it???

  • Avatar
    Benjy Boxer

    Hey there. If you have Harmony32.dll in your C:\Users\%username%\AppData\Roaming\Parsec folder on the host and the echo is not working, please confirm that you don't have a third party audio software running on your computer. Disable that third party audio software and restart Discord and Parsec. That will probably fix this echo.

  • Avatar
    Ray Cook

    I hate to add on to this, but I'm running out of ideas to troubleshoot. I have an AMD Ryzen 5 1500X with an AMD Radeon RX 580. I have excluded both C:\Program Files\Parsec and C:\Users\username\appdata\parsec from my anti-virus (Windows Defender) and as far as I am aware, have no virtual surround sound software nor any other third party audio drivers. Discord is set to the standard audio system, and I have the echo cancelling feature on in Parsec. Also, I do have Harmony32.dll in my appdata\roaming\parsec folder, but I can not find any Harmony.exe. I have restarted my PC, Discord, and Parsec multiple times. Thank you in advance for your time and help.

  • Avatar
    Benjy Boxer

    Hey. Do you have any third party software for audio running on the computer? That might be causing issues. You should try disabling that third party software. Also, Discord has reported this issue with their audio that might be impacting you - https://support.discordapp.com/hc/en-us/articles/115001134492--Known-Issue-Windows-Attenuation-Bug

  • Avatar
    Ray Cook

    As far as I know, the only third party audio software I can think of that might be running on my computer are the AMD Audio Drivers that came installed with my graphics card and I have tried to use Parsec without it to no avail. I also checked and my attenuation is turned off. Thank you again for your help.

Please sign in to leave a comment.