Lock file and bitrate problems

My parsec client is a raspberry pi 3 model b + and the server runs on a windows 10 (LAN).

I noticed that every time I run the client a file called "lock" is created in the ~/.parsec directory. If I do not delete this file before running the client, the bitrate gets stuck at 10mbps even though my setup is at 50mbps (encoder_bitrate = 50).

When I delete the file "lock" and start the client, making the connection to the server, everything is normal, that is, the 50mbps are effectively being used, as the parsec console shows on windows.

Can someone help me not to have to do this everytime I run the client?



  • UP

  • As you asked, I performed multiple test.

    Killed parsec with "killall parsec" command via ssh and reload it multiple time. Lock file is here, but I'm not sure that the bitrate is limited.

    I don't have an issue with bitrate. I use nload utility via ssh to monitor real-time bandwidth usage of the rpi, and since I modified encoder_min_qp, my average network usage is 17MB/s.

    What I can say is, sometimes, parsec takes time to use all the available bandwidth. I think, as it's mean for WAN usage, it tries to discover the amount of available bandwidth and use as start a high value of encoder compression. 

    Let me explain the behavior I think is behind this: At start, video is highly compressed, bandwidth usage is reduced. Then, parsec detect more bandwidh available and reduce compression. until you meet encoder_bitrate (maximum value) or encoder_min_qp (minimum value), it will reduce compression and use more bandwidth.

    This discovery can take time as you can observe it yourself in the console. It could be one minute or 2 before I finally use an average of 17Mb/s on my installation.

    If you still have issue, you could try to force option during launch, like this:

    parsecd server_id=YOUR_SERVER_ID:encoder_bitrate=30


    I hope it helps you.

Please sign in to leave a comment.

Didn't find what you were looking for?

New post