raspberry pi controllers.txt not being picked up

Hi folks,

 

Running parsec on my raspberry pi 3 which is using retropie. Unfortunately the controller mapping for my wireless xbox 360 controller isn't right. This isn't an issue with parsec exactly as I had similar issues when trying out moonlight. The mappings are different using parsec as they were by default using moonlight, but still - using http://html5gamepad.com/ I can see that the right stick is actually mapped to axis 2 and button 6!

Anyhow, using jstest I've come up with a custom mapping which works fine when I use it with moonlight.

030000005e040000a102000000010000,X360 Wireless Controller,a:b0,b:b1,back:b8,dpdown:b16,dpleft:b13,dpright:b14,dpup:b15,guide:b10,leftshoulder:b4,leftstick:b11,lefttrigger:b6,leftx:a0,lefty:a1,rightshoulder:b5,rightstick:b10,righttrigger:b7,rightx:a2,righty:a3,start:b9,x:b2,y:b3,

But I'm now trying to force parsec to pick it up. I've tried setting it as the only line in /home/pi/.parsec/controllers.txt but no joy. I've tried using the "reset controllers" option on the host. No joy. Obviously tried rebooting my pie as well. No joy. Every time I run parsec, the button mappings are still as they always are.

 

It wouldn't be the end of the world as parsec handily allows for remapping of controllers via the menu, but it doesn't provide options for dpad left and right oddly. So I'm without two pretty important buttons in some games.

 

Can anyone please help me get the mapping picked up.

 

Cheers

 

Pete

0

Comments

1 comment
  • Wow. Another fix. Just when you think you've tried everything. Adding 'platform:Linux,' to the end of the mapping fixed it.

     

    All working now. Hope this helps someone in the future.

Please sign in to leave a comment.

Didn't find what you were looking for?

New post